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Preface

This application note describes how to install and update the MFGTool and congatec
bootloader Profiles via the git server.

Disclaimer

The information contained within this Application Note, including but not limited to any
product specification, is subject to change without notice.

congatec AG provides no warranty with regard to this Application Note or any other
information contained herein and hereby expressly disclaims any implied warranties of
merchantability or fitness for any particular purpose with regard to any of the foregoing.
congatec AG assumes no liability for any damages incurred directly or indirectly from any
technical or typographical errors or omissions contained herein or for discrepancies between
the product and the Application Note. In no event shall congatec AG be liable for any
incidental, consequential, special, or exemplary damages, whether based on tort, contract or
otherwise, arising out of or in connection with this Application Note or any other
information contained herein or the use thereof.

Intended Audience

This Application Note is intended for technically qualified personnel. It is not intended
for general audiences.

Electrostatic Sensitive Device

All congatec AG products are electrostatic sensitive devices and are packaged
accordingly. Do not open or handle a congatec AG product except at an
electrostatic-free workstation. Additionally, do not ship or store congatec AG products
near strong electrostatic, electromagnetic, magnetic, or radioactive fields unless the
device is contained within its original manufacturer’'s packaging. Be aware that failure to
comply with these guidelines will void the congatec AG Limited Warranty.

Technical Support

congatec AG technicians and engineers are committed to providing the best possible
technical support for our customers so that our products can be easily used and
implemented. We request that you first visit our website at www.congatec.com for the
latest documentation, utilities and drivers, which have been made available to assist
you. If you still require assistance after visiting our website then contact our technical
support department by email at support@congatec.com
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Symbols

The following are symbols used in this application note.

@ Note

Notes call attention to important information that should be observed.

A Caution

Cautions warn the user about how to prevent damage to hardware or loss of data.

A Warning

Warnings indicate that personal injury can occur if the information is not observed.

Copyright Notice

Copyright © 2016, congatec AG. All rights reserved. All text, pictures and graphics are
protected by copyrights. No copying is permitted without written permission from
congatec AG.

congatec AG has made every attempt to ensure that the information in this document is
accurate yet the information contained within is supplied “as-is”.

Trademarks

Product names, logos, brands, and other trademarks featured or referred to within this
user's guide or the congatec website, are the property of their respective trademark
holders. These trademark holders are not affiliated with congatec AG, our products, or
our website.
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1 Overview

NXP's MFGTool (manufacturing tool) enables communication with iMX6-based
hardware designs (for example, conga-QMX6 or conga-UMX6) even if there is no
working bootloader program resident in the SPI-flash.

Previous releases were split up into separate MFGTool and MFG Profiles archive files.
These archives were distributed via the congatec website and driver database. The
newer releases (r006 and later) are available on the congatec public git server.

This document describes how to install and update the MFGTool and MFG Profiles via
the git server. Prior knowledge of git or version control in general is not required.
However, to follow this guide, you require a Windows operating system and the Git GUI.

Please refer to the MFGTool readme ( https://git.congatec.com/imx6-mfg-tool/mfgtool )
for information on how to use the git command line or git bash. Refer also to the
software guide for the latest information on the usage of the MFGTool.

@ Note

Always use the latest release of MFGTool and MFG Profiles to ensure your design
functions properly.
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2 Preparation

Download the 282 git binary version from the following link depending of your
processor architecture.

O=> 32-bit: https,/github.com/git-for-windows/qit/releases/download,/ 2.8 2windows.1/Git-
2.82-32-bitexe

64-bit: https.//github.com/git-for-windows/git/releases/download/v2.82.windows.1/Git-
2.82-64-bitexe

Note

Do not obtain git binaries from unofficial sources. Obtain the git binaries from the
official website ( https://github.com/git-for-windows/ ) only.

The subsequently shown settings are recommended and should be strictly applied.
1. Double-click the git binary executable file

2. Select the components as shown below:

Select Components
Which components should be installed?

Select the components you want to install; clear the components you do not want to
install. Click Next when you are ready to continue.

Additional icons
0On the Desktop

Windows Explorer integration

Git Bash Here

.- [¥] Git GUI Here

Associate .git™ configuration files with the default text editor

Associate .sh files to be run with Bash

[] use a TrueType font in all console windows

Current selection requires at least 187,5 MB of disk space.

I < Back “ Mext = ]’ Cancel
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3. Select Use Git from the Windows Component Prompt:

Adjusting your PATH environment
How would you like to use Git from the command line? v

(7) use Git from Git Bash only

This is the safest choice as your PATH will not be modified at all. You will only E
able to use the Git command line tools from Git Bash.

(@) Use Git from the Windows Command Prompt

I This option is considered safe as it only adds some minimal Git wrappers to you
PATH to avoid cluttering your environment with optional Unix tools. You will be
able to use Git from both Git Bash and the Windows Command Prompt.

(7) use Git and optional Unix tools from the Windows Command Prompt

Both Git and the optional Unix tools will be added to your PATH.
Warning: This will override Windows tools like "find" and "sort". Only
use this option if you understand the implications.

I https: /fgit-for-windaws.github, io/
l'

4. Select Checkout as-is, commit Unix-style line endings:

| <Back || Net> || cancel |

Configuring the fine ending conversions Y,
How should Git treat line endings in text files?

() checkout Windows-style, commit Unix-style line endings

Git will conwvert LF to CRLF when checking out text files. When committing
text files, CRLF will be converted to LF. For cross-platform projects,
this is the recommended setting on Windows ("core.autocrlf" is set to "true").

(@) checkout as-is, commit Unix-style line endings

L
Git will not perform any conversion when checking out text files. When
committing text files, CRLF will be converted to LF. For cross-platform projects,
this is the recommended setting on Unix ("core.autocrlf" is set to "input").
() checkout as-is, commit as-is
|

Git will not perform any conversions when checking out or committing
text files. Choosing this option is not recommended for cross-platform
projects ("core.autocrlf" is set to "false").

i https: ffgit-for-windows.github, io,/

< Back ” Mext = ]l Cancel
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5. Select Use MInTTY (the default terminal of MSYS2):

Configuring the terminal emulator to use with Git Bash Y,
Which terminal emulator do you want to use with your Git Bash? v

(@) Use MIinTTY (the default terminal of MSYS2)

Git Bash will use MinTTY as terminal emulator, which sports a resizable window
| non-rectangular selections and a Unicode font. Windows console programs ((suc
as interactive Python) must be launched via “winpty™ to work in MinTTY.

() Use Windows' default console window

I Git will use the default console window of Windows ("cmd.exe"), which works v
with Win32 conscle programs such as interactive Python or node.js, but has a
very limited default scroll-back, needs to be configured to use a Unicode font in
order to display non-ASCII characters correctly, and prior to Windows 10 its
window was not freely resizable and it only allowed rectangular text selections.

il

i https: ffgit-for-windows.github, io,/

l < Back “ Next > ]l Cancel

6. Select Enable file system caching:

Configuring extra options
Which features would you like to enable?

Enable file system caching

File system data will be read in bulk and cached in memory for certain
operations ("core.fscache" is set to "true"). This provides a significant
performance boost.

Enable Git Credential Manager

L
The Git Credential Manager for Windows provides secure Git credential storage
for Windows, most notably multi-factor authentication support for Visual Studio
Team Services and GitHub. (requires .NET framework v4.5.1 or or later)

il

https: ffgit-for-windows.github, io,/

< Back H Next > ]l Cancel
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Follow the steps below to fetch the latest MFGTool and MFG Profiles from the git

server:

1.  Choose the installation destination for the MFGTool and MFG Profiles:

a
b
C.
d

Open Windows Explorer (file manager)

Create a new directory and name it for example git_checkouts

Double-click the newly created directory git_checkouts to open it

Right-click anywhere in the open directory and click Git GUI Here

Name

&
| &

View
Sort by
Group by
Refresh

Customize this folder...

Paste

Paste shortcut
Undo Rename
Git GUI Here
Git Bash Here

Share with

SVN Checkout...
TortoiseSVN

New

Properties

Date modified

Type Size

This folder is empty.

»
»

»

Ctrl+Z

2. Click Clone Existing Repository:

Copyright © congatec AG
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& Git Gui

Repository Help

Create New Repository

Clone Existing Repaository ‘
Open Existing Repository

I+
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3. Select the repository to clone and its local target directory:

a. In the Source Location box, enter the URL of the congatec mfgtool
repository:

https://git.congatec.com/imx6-mfg-tool/mfgtool.git
b. In the Target Directory box, enter the clone’s local destination:
MEFGTool2

C. Select Recursively clone submodules too
d. Click Clone button

-

& Git Gui = |

Repository Help

Clone Existing Repository

Source Location: https://git.congatec.com/imx6-mfg-tool/mfgtool.git Browse
Target Directory: MFGTool2 Browse

_ Clone Type: Standard (Fast, Semi-Redundant, Hardlinks)
@ Full Copy (Slower, Redundant Backup)

Shared (Fastest, Not Recommended, No Backup)

Recursively clone submodules too

Clone l ’ Quit

@ Note

The /latest MFGTool and its associated MFG Profiles are now cloned into the local
target directory MFGTool2

.
& Git Gui = |

Repository Help

Cloning submodules

—

— —_—

Submodule path 'Profiles/omx6/0S Firmware/update.uboot2013': checked out 'b8£931 “
Cloning inte 'Profiles/gmx6/0S Firmware/update.uboot2013-android'...

Submodule path 'Profiles/gmx6/0S Firmware/update.uboot20l3-android': checked cut
Cloning into 'Profiles/gmx6/0S Firmware/update.uboot2016'...

Submodule path 'Profiles/qmx6/0S Firmware/update.uboot2016': checked out '"b9f7bf
Cloning into 'Profiles/aqmx6/0S Firmware/update.wec'...

Submodule path 'Profiles/qmx6/0S Firmware/update.wec': checked out '4f6518261eb5|_
Cloning into 'Profiles/umz6/0S Firmware/mfg'... I

I+

< | 11 »
Working... please wait...
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The MFGTool and MFG Profiles installation is complete if the Git GUI's main
window displays (as shown below). This window opens automatically after a

successful clone

E-, Git Gui (MFGTool2) C:/Users/, .

/Daten/Software/MFGTool2

) [ |

Current Branch: master
Unstaged Changes

< | | »

Staged Changes (Will Commit)

Repository Edit Branch Commit Merge Remote Help

Add...
Remove...

»

|

| »

-

Commit Message:

@ New Commit =) Amend Last Commit

Rescan

Stage Changed
Sign Off
Commit

| Push

< | | »

Ready.

-
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4 Configuration
Follow the next steps to finalize the installation:
1. Perform three mandatory configuration tasks:
a. On the menu bar, click Tools -> Add
E, Git Gui (MFGTool2) C:,sters7 = = = /Daten/Software/MFGTool2 t‘:' = g‘

Ready.

Repository Edit Branch Commit Merge Remote
Current Branch: master
Unstaged Changes

| ——
Staged Changes (Will Commit) q

e

|

{

@ New Commit ) Amend Last Commit

Sign Off
Commit

T Commit Message:
Rescan |
Stage Changed
Push
»

-

b.

Copyright © congatec AG

Add the entry “Update MFG Profiles” as follows:
Name: Update MFG Profiles

Command: git submodule update —--remote

-

& Add Tool - S

Add New Tool Command
Tool Details
Use '/' separators to create a submenu tree:
MName: Update MFG Profiles

Command: git submodule update ——remote|

["] Show a dialog before running

Ask the user to select a revision (sets SREVISION)
Ask the user for additional arguments (sets $ARGS)

["] Don't show the command output window

["1 Run only if a diff is selected ($FILENAME not empty)

[] Add globally Cancel || Add

AN33_lInstallation_and_Update_of _NXP_MFGTool_13.docx
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c. Add the entry “Upaate MFGToo/”as follows:

Name: Update MFGTool (!! backup your files first !!)

git reset --hard HEAD && git pull origin master
&& git submodule update --init

' )

& Add Tool

Command:

Add New Tool Command

Tool Details
Use /' separators to create a submenu tree;

Name: Update MFGTool (! backup your files first !}
Command: git reset --hard HEAD; git pull origin masted

["] Show a dialog before running
Ask the user to select a revision (sets $SREVISION)

Ask the user for additional arguments (sets $ARGS)

["] Don't show the command output window
[C] Run only if a diff is selected (SFILENAME not empty)

1 Add globally Cancel || Add

b

2. Update the MFG Profiles to the latest release as described in paragraph 5.1
3. Close Git GUI and locate the directory “MFGTo0/2".
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5 Update

51 Updating MFG Profiles

The MFG Profiles contain various bootloader images required to boot Linux, Android or
Windows Embedded Compact (WEC). To ensure, that one is burning the latest available
bootloader revision, update the MFG Profiles regularly.

To update the MFG Profiles, follow the instructions below:
1. Open the Windows Explorer (file manager)
2. Locate the directory “MFGTool2”
3. Right-click anywhere in the open directory and click Git GUI Here:

Name Date modified Type Size
git View » File folder
). Drivers Sort by » File folder
I Profiles Group by L File folder
.gitignore Refresh Text Document 1KB
.gitmodules Customize this folder.. Text Document 2KB
@] cfg.ini Paste Configuration setti... 9 KB
£ MfgTool2.exe Patie chokart Application 1,950 KB
4] MfgToolLib.dll Undo Rename Ctri+Z Application extens... 2190 K8
README <% Git GUI Here File 6 KB
&) UICfg.ini ¢% Git Bash Here Configuration setti.. 1KB
Share with »
@] SVN Checkout..
) TortoiseSVN 4
New »
Properties

4. At the menu bar, click on Tools -> Update MFG Profiles

Repository Edit Branch Commit Merge Remote Help
Current Branch: master Update MFG Profiles
Unstaged Changes Update MFGTool (!! backup your files first I')

Add.

H Remove..
[—Lk

Staged Changes (Will Commit) |, 0 |

Commit Message: @ New Commit ©) Amend Last Commit

Rescan =
Stage Changed
Sign Off
Commit
Push

< b -

Ready.

4

v d | »
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5.2 Updating MFGTool

Update the MFGTool to the latest version if you encounter an issue with a new MFG

Profile release.
Note

=>

Q

congatec

Double-check your configuration settings before you update the MFGTool, to rule

out misconfiguration.

CAUTION

A

Updating the MFGTool will overwrite all MFG related files. Create a backup in
order to prevent unintended data loss.

Steps for updating the MFGTool

AW

Name

.git

\. Drivers

i Profiles
.gitignore
.gitmodules

& cfg.ini

m MfgTool2.exe

4] MfgToolLib.dll
README

;| UICfg.ini

Copyright © congatec AG

Open the Explorer (file manager)
Double-click the directory MFGTooI2
Backup the modified files (cfg.ini, ucl2.xml, etc)

Right-click anywhere in the open directory and click Git GUI Here

Date modified

View

Sort by

Group by

Refresh

Customize this folder...
Paste

Paste shortcut

Undo Rename

Git GUI Here

Git Bash Here

Share with

SVN Checkout...
TortoiseSVN

New

Properties

Ctri+Z

Printed versions of this document are not under revision control

Type

File folder
File folder
File folder
Text Document

Text Document

Configuration setti...

Application

Application extens...

rie

Configuration setti...
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5. On the menu bar, click on Tools -> Update MFGTool

Repository Edit Branch Commit Merge Remote Help
Current Branch: master Update MFG Profiles '
Unstaged changs
= Add.. =
Remove..
2l —
Staged Changes (Will Commi) |, | | :
- Commit Message: @ New Commit ) Amend Last Commit
Rescan i
Stage Changed
Sign Off
Commit
5 Push
R —— -
Ready. —
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